0%
Posted inNumérique

Update to v5 broke my instance

d71a876ab463922f105d212d0610fe9980892118 Update to v5 broke my instance

Hi all,

I updated my instance last night following the instructions in the release notes but my instance can no longer start. Looking for some help!

Here is the log:

peertube[19079]: /var/www/peertube/versions/peertube-v5.0.0/dist/server/helpers/core-utils.js:60
peertube[19079]: throw new Error(`Duration ${duration} could not be properly parsed`);
peertube[19079]: ^
peertube[19079]: Error: Duration undefined could not be properly parsed
peertube[19079]: at parseDurationToMs (/var/www/peertube/versions/peertube-v5.0.0/dist/server/helpers/core-utils.js:60:11)
peertube[19079]: at /var/www/peertube/versions/peertube-v5.0.0/dist/server/initializers/config.js:538:61
peertube[19079]: at Array.map (<anonymous>)
peertube[19079]: at buildVideosRedundancy (/var/www/peertube/versions/peertube-v5.0.0/dist/server/initializers/config.js:536:17)
peertube[19079]: at Object.<anonymous> (/var/www/peertube/versions/peertube-v5.0.0/dist/server/initializers/config.js:207:25)
peertube[19079]: at Module._compile (node:internal/modules/cjs/loader:1159:14)
peertube[19079]: at Module._extensions..js (node:internal/modules/cjs/loader:1213:10)
peertube[19079]: at Module.load (node:internal/modules/cjs/loader:1037:32)
peertube[19079]: at Module._load (node:internal/modules/cjs/loader:878:12)
peertube[19079]: at Module.require (node:internal/modules/cjs/loader:1061:19)
peertube[19079]: Node.js v18.12.1
systemd[1]: peertube.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: peertube.service: Failed with result 'exit-code'.

Source


Laisser un commentaire